Opened 13 years ago

Closed 9 years ago

Last modified 7 years ago

#34 closed defect (use support list)

error calculating Multi Target

Reported by: human Owned by: somebody
Version: Keywords:
Cc:

Description

I need to show one of graphs as differnce between two ports.

Part of .cfg file:

Target[istrf]: -#Fa5/12:xxx@cat-6509: - #Fa5/43:xxx@cat-6509:

Both Fa5/12 and Fa5/43 graphs displayed correctly, but istrf graph periodically shows unnormous "peaks". I think that is because counter overflows, which processed right when calculating single target, but with error when we using multi target.

Examples of all three .log's and istrf-day.png in attach.

Attachments (4)

cat-6509.is.lan_fa5_12.log (77.4 KB) - added by human 13 years ago.
cat-6509.is.lan_fa5_43.log (59.1 KB) - added by human 13 years ago.
istrf.log (48.5 KB) - added by human 13 years ago.
istrf-day.png (2.3 KB) - added by human 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by human

Changed 13 years ago by human

Changed 13 years ago by human

Changed 13 years ago by human

comment:1 Changed 13 years ago by human

I'm sorry to not supply additional info.

mrtg v.2.15.2

If you need additional feedback please contact me by e-mail ivb@…

comment:2 Changed 9 years ago by oetiker

  • Resolution set to use support list
  • Status changed from new to closed

the problem is that mrtg builds the difference between the two input values and only later builds the diffs ... this causes spikes as the counters wrap. for a better solution, use rrdtool with STACK.

cheers tobi

Note: See TracTickets for help on using tickets.
 

NOTE: The content of this website is accessible with any browser. The graphical design though relies completely on CSS2 styles. If you see this text, this means that your browser does not support CSS2. Consider upgrading to a standard conformant browser like Mozilla Firefox or Opera but also Apple's Safari or KDE's Konqueror for example.