Opened 7 years ago

Last modified 7 years ago

#134 new defect

problem with Subroutine SNMP_Session::pack_sockaddr_in6 redefined

Reported by: human Owned by:
Version: Keywords: pack_sockaddr_in6 redefinition
Cc:

Description

Hello. I have compiled and installed mrtg version 2.17.4 on a 32-bit OpenSuse? 12.1 system based on vmware esxi 4.1 standalone. My perl version is 5.14.2. I get this error for every mrtg run (I am using calls through crontab for every config file used, 5 config files totaly): Subroutine SNMP_Session::pack_sockaddr_in6 redefined at /usr/lib/perl5/5.14.2/Exporter.pm line 67.

at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_Session.pm line 149

Subroutine SNMP_Session::unpack_sockaddr_in6 redefined at /usr/lib/perl5/5.14.2/Exporter.pm line 67.

at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_Session.pm line 149

Subroutine SNMPv1_Session::pack_sockaddr_in6 redefined at /usr/lib/perl5/5.14.2/Exporter.pm line 67.

at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_Session.pm line 604

Subroutine SNMPv1_Session::unpack_sockaddr_in6 redefined at /usr/lib/perl5/5.14.2/Exporter.pm line 67.

at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_Session.pm line 604

I am not using IPv6 (Disabled in OS and mrtg config files). I have more than one installation of mrtg but the rest are 11.x OpenSuse? and earlier perl versions so I don't get that error. I have looked in bug reports for OpenSuse? and FreeBSD and the problem is mentioned there too, but the solutions do not apply to me (I do not want to downgrade perl and I am not using the daemon option in mrtg). I tried running mrtg through the command line using env LANG=C first but the result is the same. Any ideas? MRTG does collect data normally but my email gets trampled by all the errors so I would really like a solution to this ( I am hoping to upgrade all my systems to current versions but I would like to have a solution first). Keep up the good work, you are the best! I hope you get mrtg with rrd working soon, the file io in my mrtg machines is killing them.. I tried the SteveShipway? approach but it doesn't work for me (the ui is not what I want and no zoom/custom graphs like in smokeping). Ioannis Theodoridis Bank of Greece Network & Communications Support Department.

Change History (3)

comment:1 Changed 7 years ago by oetiker

please test r405

comment:2 Changed 7 years ago by human

Thank you for the reply. I have tried this: http://tasos.pavta.com/myblog/2012/06/16/subroutine-snmp_sessionpack_sockaddr_in6-redefined/ which seems to fix the issue. It seems to me that it is a similar approach but yours seems to remedy the problem at the source. I will try your fix on my next installation upgrade and let you know how it goes. Thank you again Tobi, excellent work! Ioannis.

Note: See TracTickets for help on using tickets.
 

NOTE: The content of this website is accessible with any browser. The graphical design though relies completely on CSS2 styles. If you see this text, this means that your browser does not support CSS2. Consider upgrading to a standard conformant browser like Mozilla Firefox or Opera but also Apple's Safari or KDE's Konqueror for example.